From gregskinner0 at icloud.com Fri Oct 2 13:19:07 2026 From: gregskinner0 at icloud.com (Greg Skinner) Date: Fri, 2 Oct 2026 13:19:07 -0700 Subject: [ih] Fwd: DTIC is unavailable for public access! References: <2043730475.94869.1790971799755@mail.yahoo.com> Message-ID: <04C3767A-C4CA-4096-A53D-15B7F505BDEF@icloud.com> Forwarded for Barbara > From: Barbara Denny > To: Internet-history > Sent: Friday, October 2, 2026 at 12:59:33 PM PDT > Subject: DTIC is unavailable for public access! > > I am unhappy to report that I just discovered DTIC is no longer searchable for public users, like us! The website says it is only temporary while they improve (????) the site but one quick search says it has been gone since sometime in August. All material I ever saw seemed to have the appropriate vetting as the documents were marked for public access. It sounds like some groups have complained but I found no info on when it will be restored. > > barbara From jack at 3kitty.org Fri Oct 2 13:58:07 2026 From: jack at 3kitty.org (Jack Haverty) Date: Fri, 2 Oct 2026 13:58:07 -0700 Subject: [ih] Fwd: DTIC is unavailable for public access! In-Reply-To: <04C3767A-C4CA-4096-A53D-15B7F505BDEF@icloud.com> References: <2043730475.94869.1790971799755@mail.yahoo.com> <04C3767A-C4CA-4096-A53D-15B7F505BDEF@icloud.com> Message-ID: <96cb15ac-2869-4221-9050-724d996279b7@3kitty.org> If you know the ADA number a DTIC document may still be accessible by searching on archive.org? ?For example, here's one I wrote: https://web.archive.org/web/20250202074233/https://apps.dtic.mil/sti/tr/pdf/ADA121350.pdf /Jack Haverty On 10/2/26 13:19, Greg Skinner via Internet-history wrote: > Forwarded for Barbara > >> From: Barbara Denny >> To: Internet-history >> Sent: Friday, October 2, 2026 at 12:59:33 PM PDT >> Subject: DTIC is unavailable for public access! >> >> I am unhappy to report that I just discovered DTIC is no longer searchable for public users, like us! The website says it is only temporary while they improve (????) the site but one quick search says it has been gone since sometime in August. All material I ever saw seemed to have the appropriate vetting as the documents were marked for public access. It sounds like some groups have complained but I found no info on when it will be restored. >> >> barbara -------------- next part -------------- A non-text attachment was scrubbed... Name: OpenPGP_signature.asc Type: application/pgp-signature Size: 665 bytes Desc: OpenPGP digital signature URL: From b_a_denny at yahoo.com Fri Oct 2 18:20:20 2026 From: b_a_denny at yahoo.com (Barbara Denny) Date: Sat, 3 Oct 2026 01:20:20 +0000 (UTC) Subject: [ih] Potential URL for technical reports References: <133554393.142750.1790990420690.ref@mail.yahoo.com> Message-ID: <133554393.142750.1790990420690@mail.yahoo.com> https://ntrl.ntis.gov/NTRL/ I haven't had a chance to poke really.? I am having trouble downloading the documents but i am at least getting a list of? accession numbers that seem somewhat? relevant to my search.? The site is slow? Website courtesy of gemini barbara From jtk at dataplane.org Sat Oct 3 09:26:16 2026 From: jtk at dataplane.org (John Kristoff) Date: Sat, 3 Oct 2026 11:26:16 -0500 Subject: [ih] Why did DCCP fail to gain traction? Message-ID: <20261003112616.3aa794d0@dataplane.org> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet history. I don't think it ever really saw much, if any, deployment or support in applications. It was removed from the Linux kernel last year. Was it too late, too complex, too little, or just deemed unnecessary given available alternatives such as QUIC? I don't recall seeing much discussion about why it failed to gain traction and I'm interested to hear what the collective wisdom of this group might have to say about that. John From tho.ietf at gmail.com Sat Oct 3 09:46:13 2026 From: tho.ietf at gmail.com (Thomas Fossati) Date: Sat, 3 Oct 2026 18:46:13 +0200 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <20261003112616.3aa794d0@dataplane.org> References: <20261003112616.3aa794d0@dataplane.org> Message-ID: On Sat, Oct 3, 2026 at 6:26?PM John Kristoff via Internet-history wrote: > > DCCP (IETF RFC 4330) is/was a relatively new transport in Internet > history. I don't think it ever really saw much, if any, deployment or > support in applications. It was removed from the Linux kernel last year. > > Was it too late, too complex, too little, or just deemed unnecessary > given available alternatives such as QUIC? I don't recall seeing > much discussion about why it failed to gain traction and I'm interested > to hear what the collective wisdom of this group might have to say about > that. It failed because of an abundance of middleboxes and a lack of APIs. Unlike SCTP (which is similarly affected by middleboxes), it never found a niche where it could be safely deployed. Then came QUIC, which made it completely redundant. That's my rough understanding of the situation. cheers! > > John > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history -- Thomas From carsten at schiefner.berlin Sat Oct 3 10:29:34 2026 From: carsten at schiefner.berlin (Carsten Schiefner) Date: Sat, 3 Oct 2026 19:29:34 +0200 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <20261003112616.3aa794d0@dataplane.org> References: <20261003112616.3aa794d0@dataplane.org> Message-ID: <6b172af8-0a1b-d149-143b-9e82fcfb73f0@schiefner.berlin> Small nit picking if I may, John...? It's RFC 43_4_0: RFC 4340: Datagram Congestion Control Protocol (DCCP) https://www.rfc-editor.org/info/rfc4340/ I stumbled over RFC 4330: RFC 4330: Simple Network Time Protocol (SNTP) Version 4 for IPv4, IPv6 and OSI https://www.rfc-editor.org/info/rfc4330/ and was pretty sure that this is quite obviously *not* it. Best, -C. On 03.10.2026 18:26, John Kristoff via Internet-history wrote: > DCCP (IETF RFC 4330) is/was a relatively new transport in Internet > history. I don't think it ever really saw much, if any, deployment or > support in applications. It was removed from the Linux kernel last year. > > Was it too late, too complex, too little, or just deemed unnecessary > given available alternatives such as QUIC? I don't recall seeing > much discussion about why it failed to gain traction and I'm interested > to hear what the collective wisdom of this group might have to say about > that. > > John From jtk at dataplane.org Sat Oct 3 10:47:05 2026 From: jtk at dataplane.org (John Kristoff) Date: Sat, 3 Oct 2026 12:47:05 -0500 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <6b172af8-0a1b-d149-143b-9e82fcfb73f0@schiefner.berlin> References: <20261003112616.3aa794d0@dataplane.org> <6b172af8-0a1b-d149-143b-9e82fcfb73f0@schiefner.berlin> Message-ID: <20261003124705.460097e0@dataplane.org> On Sat, 3 Oct 2026 19:29:34 +0200 Carsten Schiefner via Internet-history wrote: > Small nit picking if I may, John...? > It's RFC 43_4_0: Yes, of course. Thanks for catching the typo. John From brian.e.carpenter at gmail.com Sat Oct 3 13:22:20 2026 From: brian.e.carpenter at gmail.com (Brian E Carpenter) Date: Sun, 4 Oct 2026 09:22:20 +1300 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: References: <20261003112616.3aa794d0@dataplane.org> Message-ID: <15009287-d520-4fca-afd0-f7bdb126e8c8@gmail.com> On 04-Oct-26 05:46, Thomas Fossati via Internet-history wrote: > On Sat, Oct 3, 2026 at 6:26?PM John Kristoff via Internet-history > wrote: >> >> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet >> history. I don't think it ever really saw much, if any, deployment or >> support in applications. It was removed from the Linux kernel last year. >> >> Was it too late, too complex, too little, or just deemed unnecessary >> given available alternatives such as QUIC? I don't recall seeing >> much discussion about why it failed to gain traction and I'm interested >> to hear what the collective wisdom of this group might have to say about >> that. > > It failed because of an abundance of middleboxes and a lack of APIs. > Unlike SCTP (which is similarly affected by middleboxes), it never > found a niche where it could be safely deployed. That's certainly true, but I think that in reality there was no operational problem that "congestion-controlled unreliable datagrams" would solve more cheaply than simply buying extra bandwidth. I see that Linux proactively removed DCCP support from Linux 6.16. Brian > Then came QUIC, which made it completely redundant. > > That's my rough understanding of the situation. > > cheers! > >> >> John >> -- >> Internet-history mailing list >> Internet-history at elists.isoc.org >> https://elists.isoc.org/mailman/listinfo/internet-history >> - >> Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > > > From tho.ietf at gmail.com Sat Oct 3 13:56:56 2026 From: tho.ietf at gmail.com (Thomas Fossati) Date: Sat, 3 Oct 2026 22:56:56 +0200 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <15009287-d520-4fca-afd0-f7bdb126e8c8@gmail.com> References: <20261003112616.3aa794d0@dataplane.org> <15009287-d520-4fca-afd0-f7bdb126e8c8@gmail.com> Message-ID: On Sat, Oct 3, 2026 at 10:22?PM Brian E Carpenter wrote: > > On 04-Oct-26 05:46, Thomas Fossati via Internet-history wrote: > > On Sat, Oct 3, 2026 at 6:26?PM John Kristoff via Internet-history > > wrote: > >> > >> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet > >> history. I don't think it ever really saw much, if any, deployment or > >> support in applications. It was removed from the Linux kernel last year. > >> > >> Was it too late, too complex, too little, or just deemed unnecessary > >> given available alternatives such as QUIC? I don't recall seeing > >> much discussion about why it failed to gain traction and I'm interested > >> to hear what the collective wisdom of this group might have to say about > >> that. > > > > It failed because of an abundance of middleboxes and a lack of APIs. > > Unlike SCTP (which is similarly affected by middleboxes), it never > > found a niche where it could be safely deployed. > > That's certainly true, but I think that in reality there was no operational > problem that "congestion-controlled unreliable datagrams" would solve more > cheaply than simply buying extra bandwidth. Yes, you are right. Besides, I reckon that ABR may have also helped to solve, for a significant proportion of Internet traffic, some of the problems that DCCP was designed to tackle. > I see that Linux proactively removed DCCP support from Linux 6.16. For the past ~10 years, the Linux community has been maintaining a protocol that no one really uses. It made total sense to drop it. -- Thomas From jack at 3kitty.org Sat Oct 3 13:58:08 2026 From: jack at 3kitty.org (Jack Haverty) Date: Sat, 3 Oct 2026 13:58:08 -0700 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: References: <20261003112616.3aa794d0@dataplane.org> Message-ID: In addition to technical issues, I think there was another reason for "failing to gain traction".? It comes down to management, or lack thereof, of new technology in an evolving infrastructure service. Personally, I'm just one of billions of users of the Internet now. ?But I was pretty heavily involved in the technology during the early years.? ?Today, my home LAN is an eclectic mix of devices, all on the Internet.? There are desktops and servers, running Windows, IOS, or Ubuntu.? ?There are phones, tablets, both Android and Apple systems, and even a few Raspberry Pis.? ?Several irrigation controllers and other home automation stuff.? Probably a bunch of things I've forgotten.? Even the fan in my attic is on the Internet. I have no idea whether or not any of those devices use, or even are capable of using, DCCP.? DCCP is not alone - As just a user, I haven't heard about SCTP either, or many of the other technology that the IETF has documented in RFCs and placed "on the shelf" for anyone to use.? I've heard a little about QUIC, but don't know how to tell if any of my devices can or do use it.? Or why they should. ?I suspect most of the billions of Users have similar experiences. Looking outward, I see lots of ads for new devices to attach to my LAN.? But I can't recall ever seeing any ad that highlighted some product as "Supports DCCP!!".? ?Or "QUIC!", or "SCTP!", or even "IPv6!".? ?Companies traditionally tout the benefits of their products over the competition, and implement the features that their customers demand.? For some reason that doesn't seem to happen for Internet technology. Back in 1983, a major effort was involved to transition the existing ARPANET from its old technology (called NCP) to the new TCP mechanisms.? That was accomplished on January 1, 1983, after several years of planning and preparing.? After that date, TCP was used everywhere, and NCP was no longer present anywhere. Afterwards, we realized that such transitions were a lot of work, and that particular transition was greatly aided by the fact that the entire Internet at the time was owned and managed by a combination of ARPA and DCA, i.e., part of the US Department of Defense.? ?They were definitely "in charge." We also realized that such a scheme wouldn't have the same advantage as the Internet grew and many more players got involved.? No one would be "in charge" and have the ability to orchestrate the introduction of new technology, as well as the removal of the older technology which it replaced.? Without both steps, the technical machinery would just get more and more complex and difficult to operate. But no one in 1983 knew how to do that for the Internet.? It was possible that some lessons could be learned from the experience of the telephony system, which had pretty much succeeded at creating a multi-vendor and global voice service.? ?But the topic was still viewed as a research area, likely involving considerable research and trial and error to find some techniques that would work to not only introduce some new technology, but also to remove any old technology that was no longer appropriate. The question for the research community was "How do you build a multi-vendor global communications system that can evolve with new protocols, algorithms, and techniques, and removal of the old technology that are to be replaced?" As far as I can tell, that hasn't been answered yet.? ?It's been more than 40 years.? Maybe it's just not possible? /Jack Haverty On 10/3/26 09:46, Thomas Fossati via Internet-history wrote: > On Sat, Oct 3, 2026 at 6:26?PM John Kristoff via Internet-history > wrote: >> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet >> history. I don't think it ever really saw much, if any, deployment or >> support in applications. It was removed from the Linux kernel last year. >> >> Was it too late, too complex, too little, or just deemed unnecessary >> given available alternatives such as QUIC? I don't recall seeing >> much discussion about why it failed to gain traction and I'm interested >> to hear what the collective wisdom of this group might have to say about >> that. > It failed because of an abundance of middleboxes and a lack of APIs. > Unlike SCTP (which is similarly affected by middleboxes), it never > found a niche where it could be safely deployed. > Then came QUIC, which made it completely redundant. > > That's my rough understanding of the situation. > > cheers! > >> John >> -- >> Internet-history mailing list >> Internet-history at elists.isoc.org >> https://elists.isoc.org/mailman/listinfo/internet-history >> - >> Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > > -------------- next part -------------- A non-text attachment was scrubbed... Name: OpenPGP_signature.asc Type: application/pgp-signature Size: 665 bytes Desc: OpenPGP digital signature URL: From sob at sobco.com Sat Oct 3 15:26:31 2026 From: sob at sobco.com (Scott O. Bradner) Date: Sat, 3 Oct 2026 18:26:31 -0400 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: References: <20261003112616.3aa794d0@dataplane.org> Message-ID: at some level, DCCP was designed to solve the problem (middle boxes blocking non tcp/udp protocols - Quick (RFC 9000) has done a fine job of solving that (and evolving the net to answer Jack?s last question Scott > On Oct 3, 2026, at 4:58?PM, Jack Haverty via Internet-history wrote: > > In addition to technical issues, I think there was another reason for "failing to gain traction". It comes down to management, or lack thereof, of new technology in an evolving infrastructure service. > > Personally, I'm just one of billions of users of the Internet now. But I was pretty heavily involved in the technology during the early years. Today, my home LAN is an eclectic mix of devices, all on the Internet. There are desktops and servers, running Windows, IOS, or Ubuntu. There are phones, tablets, both Android and Apple systems, and even a few Raspberry Pis. Several irrigation controllers and other home automation stuff. Probably a bunch of things I've forgotten. Even the fan in my attic is on the Internet. > > I have no idea whether or not any of those devices use, or even are capable of using, DCCP. DCCP is not alone - As just a user, I haven't heard about SCTP either, or many of the other technology that the IETF has documented in RFCs and placed "on the shelf" for anyone to use. I've heard a little about QUIC, but don't know how to tell if any of my devices can or do use it. Or why they should. I suspect most of the billions of Users have similar experiences. > > Looking outward, I see lots of ads for new devices to attach to my LAN. But I can't recall ever seeing any ad that highlighted some product as "Supports DCCP!!". Or "QUIC!", or "SCTP!", or even "IPv6!". Companies traditionally tout the benefits of their products over the competition, and implement the features that their customers demand. For some reason that doesn't seem to happen for Internet technology. > > Back in 1983, a major effort was involved to transition the existing ARPANET from its old technology (called NCP) to the new TCP mechanisms. That was accomplished on January 1, 1983, after several years of planning and preparing. After that date, TCP was used everywhere, and NCP was no longer present anywhere. > > Afterwards, we realized that such transitions were a lot of work, and that particular transition was greatly aided by the fact that the entire Internet at the time was owned and managed by a combination of ARPA and DCA, i.e., part of the US Department of Defense. They were definitely "in charge." > > We also realized that such a scheme wouldn't have the same advantage as the Internet grew and many more players got involved. No one would be "in charge" and have the ability to orchestrate the introduction of new technology, as well as the removal of the older technology which it replaced. Without both steps, the technical machinery would just get more and more complex and difficult to operate. > > But no one in 1983 knew how to do that for the Internet. It was possible that some lessons could be learned from the experience of the telephony system, which had pretty much succeeded at creating a multi-vendor and global voice service. But the topic was still viewed as a research area, likely involving considerable research and trial and error to find some techniques that would work to not only introduce some new technology, but also to remove any old technology that was no longer appropriate. > > The question for the research community was "How do you build a multi-vendor global communications system that can evolve with new protocols, algorithms, and techniques, and removal of the old technology that are to be replaced?" > > As far as I can tell, that hasn't been answered yet. It's been more than 40 years. Maybe it's just not possible? > > /Jack Haverty > > > On 10/3/26 09:46, Thomas Fossati via Internet-history wrote: >> On Sat, Oct 3, 2026 at 6:26?PM John Kristoff via Internet-history >> wrote: >>> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet >>> history. I don't think it ever really saw much, if any, deployment or >>> support in applications. It was removed from the Linux kernel last year. >>> >>> Was it too late, too complex, too little, or just deemed unnecessary >>> given available alternatives such as QUIC? I don't recall seeing >>> much discussion about why it failed to gain traction and I'm interested >>> to hear what the collective wisdom of this group might have to say about >>> that. >> It failed because of an abundance of middleboxes and a lack of APIs. >> Unlike SCTP (which is similarly affected by middleboxes), it never >> found a niche where it could be safely deployed. >> Then came QUIC, which made it completely redundant. >> >> That's my rough understanding of the situation. >> >> cheers! >> >>> John >>> -- >>> Internet-history mailing list >>> Internet-history at elists.isoc.org >>> https://elists.isoc.org/mailman/listinfo/internet-history >>> - >>> Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history >> >> > > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history From johnl at iecc.com Sat Oct 3 17:56:56 2026 From: johnl at iecc.com (John Levine) Date: 3 Oct 2026 20:56:56 -0400 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: References: <20261003112616.3aa794d0@dataplane.org> Message-ID: <20261004005657.46EAE1228B0D6@ary.qy> It appears that Jack Haverty via Internet-history said: >The question for the research community was "How do you build a >multi-vendor global communications system that can evolve with new >protocols, algorithms, and techniques, and removal of the old technology >that are to be replaced?" Dunno about removal of the old stuff but QUIC is a good example of how protocols evolve. HTTP version 1 and 2 ran over TCP, http/3 runs over QUIC which is built on UDP so it doesn't need kernel support, with all the multiplexing and flow control in the application. They added a new HTTPS DNS record that browsers can query to see if a site has http/3 support. Wikipedia says that Chrome, Edge, Firefox, and Safari have all supported http/3 and QUIC for several years, and about 40% of Google's and Facebook's web traffic now runs over QUIC. The popular open source web server NGINX has QUIC support, which it appears you can enable with a one or two line configuration change. I don't think the earlier versions of http will ever go away, but given that a megabyte is a rounding error in application code sizes these days I don't see that as much of a problem. R's, John From brian.e.carpenter at gmail.com Sat Oct 3 18:40:54 2026 From: brian.e.carpenter at gmail.com (Brian E Carpenter) Date: Sun, 4 Oct 2026 14:40:54 +1300 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <20261004005657.46EAE1228B0D6@ary.qy> References: <20261003112616.3aa794d0@dataplane.org> <20261004005657.46EAE1228B0D6@ary.qy> Message-ID: <96e4de11-c329-4105-9bef-5e3e7c6222d2@gmail.com> > so it doesn't need kernel support I don't think everbody realises how critical that is. Getting updated user-space code deployed is a solved problem. Getting a kernel update deployed is very hard work that needs earthquake-sized incentives applying to a few major corporations, several open-source communities, and all operators. As far as I can tell, DCCP was never implemented in any commercial operating system kernel. Effectively, it was DOA. As an example, IPv6 availability to Google clients only started hitting 50% peaks in July 2026 (32 years after the original IPv6 announcement). I believe that QUIC was carefully conceived to avoid this trap. Regards/Ng? mihi Brian Carpenter On 04-Oct-26 13:56, John Levine via Internet-history wrote: > It appears that Jack Haverty via Internet-history said: >> The question for the research community was "How do you build a >> multi-vendor global communications system that can evolve with new >> protocols, algorithms, and techniques, and removal of the old technology >> that are to be replaced?" > > Dunno about removal of the old stuff but QUIC is a good example of how > protocols evolve. HTTP version 1 and 2 ran over TCP, http/3 runs over > QUIC which is built on UDP so it doesn't need kernel support, with all > the multiplexing and flow control in the application. They added a new > HTTPS DNS record that browsers can query to see if a site has http/3 > support. Wikipedia says that Chrome, Edge, Firefox, and Safari have > all supported http/3 and QUIC for several years, and about 40% of > Google's and Facebook's web traffic now runs over QUIC. > > The popular open source web server NGINX has QUIC support, which it appears > you can enable with a one or two line configuration change. > > I don't think the earlier versions of http will ever go away, but given > that a megabyte is a rounding error in application code sizes these days > I don't see that as much of a problem. > > R's, > John From johnl at iecc.com Sat Oct 3 19:31:30 2026 From: johnl at iecc.com (John R. Levine) Date: 3 Oct 2026 22:31:30 -0400 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <3cc0f562-8f2b-4ee5-861d-3f212c8cf8fa@dcrocker.net> References: <20261003112616.3aa794d0@dataplane.org> <20261004005657.46EAE1228B0D6@ary.qy> <3cc0f562-8f2b-4ee5-861d-3f212c8cf8fa@dcrocker.net> Message-ID: <7ee2c0eb-27a4-0abe-29f5-7efbebfdac93@iecc.com> On Sun, 4 Oct 2026, Dave Crocker wrote: > On 10/3/2026 5:56 PM, John Levine via Internet-history wrote: >> HTTP version 1 and 2 ran over TCP, http/3 runs over >> QUIC which is built on UDP so it doesn't need kernel support, with all >> the multiplexing and flow control in the application > Why can't TCP run in the application? > What does it require that UDP+QUIC don't also require? Nothing, give or take some way to route the individual protocol 6 packets to the application. If TCP weren't already in every operating system for historical reasons, I suspect we'd have a QUIC-lite for applications where a single stream is adequate. I see that there is a kernel implementation of QUIC for linux that might be faster and makes it easier to integrate into SMB an NFS which are also in the kernel. It doesn't seem to be much faster than the user library version. For client systems, speed isn't very important since the machines that web browsers run on are rarely CPU bound. High volume servers like Google's run on highly customized hardware and software so I suppose if there were a benefit to putting QUIC in the kernel on those systems, they'd just do it. R's, John From johnl at iecc.com Sat Oct 3 19:43:09 2026 From: johnl at iecc.com (John Levine) Date: 4 Oct 2026 02:43:09 -0000 Subject: [ih] QUIC history, Why did DCCP fail to gain traction? In-Reply-To: <3cc0f562-8f2b-4ee5-861d-3f212c8cf8fa@dcrocker.net> <20261004005657.46EAE1228B0D6@ary.qy> <7ee2c0eb-27a4-0abe-29f5-7efbebfdac93@iecc.com> References: <3cc0f562-8f2b-4ee5-861d-3f212c8cf8fa@dcrocker.net> <20261004005657.46EAE1228B0D6@ary.qy> <7ee2c0eb-27a4-0abe-29f5-7efbebfdac93@iecc.com> Message-ID: <119seft$2l2t$1@gal.iecc.com> According to John R. Levine via Internet-history : >On Sun, 4 Oct 2026, Dave Crocker wrote: >> On 10/3/2026 5:56 PM, John Levine via Internet-history wrote: >>> HTTP version 1 and 2 ran over TCP, http/3 runs over >>> QUIC which is built on UDP so it doesn't need kernel support, with all >>> the multiplexing and flow control in the application > >> Why can't TCP run in the application? >> What does it require that UDP+QUIC don't also require? > >Nothing, give or take some way to route the individual protocol 6 packets >to the application. If TCP weren't already in every operating system for >historical reasons, I suspect we'd have a QUIC-lite for applications where >a single stream is adequate. More apropos to Brian's point, if we had to wait for kernel implementations of new protocols, we'd wait forever. QUIC doing it backwards, first in user code, then migrate into the kernel eventually is a lot more practical. R's, John -- Regards, John Levine, johnl at taugh.com, Primary Perpetrator of "The Internet for Dummies", Please consider the environment before reading this e-mail. https://jl.ly From b_a_denny at yahoo.com Sat Oct 3 22:47:21 2026 From: b_a_denny at yahoo.com (Barbara Denny) Date: Sun, 4 Oct 2026 05:47:21 +0000 (UTC) Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <7ee2c0eb-27a4-0abe-29f5-7efbebfdac93@iecc.com> References: <20261003112616.3aa794d0@dataplane.org> <20261004005657.46EAE1228B0D6@ary.qy> <3cc0f562-8f2b-4ee5-861d-3f212c8cf8fa@dcrocker.net> <7ee2c0eb-27a4-0abe-29f5-7efbebfdac93@iecc.com> Message-ID: <1899744346.308268.1791092841590@mail.yahoo.com> Just a reminder, QUIC has a minimum mtu of 1200 bytes.?? IPv4 only requires support for 576 bytes. barbara On Saturday, October 3, 2026 at 07:31:40 PM PDT, John R. Levine via Internet-history wrote: On Sun, 4 Oct 2026, Dave Crocker wrote: > On 10/3/2026 5:56 PM, John Levine via Internet-history wrote: >> HTTP version 1 and 2 ran over TCP, http/3 runs over >> QUIC which is built on UDP so it doesn't need kernel support, with all >> the multiplexing and flow control in the application > Why can't TCP run in the application? > What does it require that UDP+QUIC don't also require? Nothing, give or take some way to route the individual protocol 6 packets to the application.? If TCP weren't already in every operating system for historical reasons, I suspect we'd have a QUIC-lite for applications where a single stream is adequate. I see that there is a kernel implementation of QUIC for linux that might be faster and makes it easier to integrate into SMB an NFS which are also in the kernel.? It doesn't seem to be much faster than the user library version. For client systems, speed isn't very important since the machines that web browsers run on are rarely CPU bound. High volume servers like Google's run on highly customized hardware and software so I suppose if there were a benefit to putting QUIC in the kernel on those systems, they'd just do it. R's, John -- Internet-history mailing list Internet-history at elists.isoc.org https://elists.isoc.org/mailman/listinfo/internet-history - Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history From roland.bless at kit.edu Mon Oct 5 02:29:06 2026 From: roland.bless at kit.edu (Bless, Roland (TM)) Date: Mon, 5 Oct 2026 11:29:06 +0200 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <20261003112616.3aa794d0@dataplane.org> References: <20261003112616.3aa794d0@dataplane.org> Message-ID: <87813c62-b5c8-4f03-8bd2-af56e29bdd9a@kit.edu> Hi, my perception was that at the time DCCP was designed, there was a fear that especially an increasing amount of multimedia streams may cause congestion problems and it would be better to to solve them in a single protocol rather than letting the application developers do it "somehow" (and maybe neglecting ECN support etc.). See also the section 2 of RFC4340 https://datatracker.ietf.org/doc/html/rfc4340#section-2 However, given the development of WebRTC and DASH, people used rather their own application-specific congestion control mechanisms instead. For example, WebRTC used more fine-grained RTCP-based feedback (see also RFC8888) and there were other approaches developed in the (concluded) RMCAT WG (https://datatracker.ietf.org/wg/rmcat/about/) as well such as NADA (RFC8698) and SCReAM (RFC8298). The reasons why DCCP had seen no real deployment are probably manifold, but I guess that NAT/FW traversal for DCCP as well as the easier development and change process in the user space contributed to this (as others noted, this also helped QUIC development and was a deliberate design choice). FWIW, there has been recent work in the IETF on Multipath-DCCP https://datatracker.ietf.org/doc/rfc9897/ to support a special use case for providing an MP-DCCP proxy inside a provider network. The idea was to also support QUIC and other UDP-based protocols. So I disagree that QUIC development hindered DCCP deployment already, the work on Media over QUIC (MOQ) started only 2022. Regards, Roland On 03.10.26 at 18:26 John Kristoff via Internet-history wrote: > DCCP (IETF RFC 4330) is/was a relatively new transport in Internet > history. I don't think it ever really saw much, if any, deployment or > support in applications. It was removed from the Linux kernel last year. > > Was it too late, too complex, too little, or just deemed unnecessary > given available alternatives such as QUIC? I don't recall seeing > much discussion about why it failed to gain traction and I'm interested > to hear what the collective wisdom of this group might have to say about > that. From lars at eggert.org Wed Oct 7 01:49:32 2026 From: lars at eggert.org (Lars Eggert) Date: Wed, 7 Oct 2026 11:49:32 +0300 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <87813c62-b5c8-4f03-8bd2-af56e29bdd9a@kit.edu> References: <20261003112616.3aa794d0@dataplane.org> <87813c62-b5c8-4f03-8bd2-af56e29bdd9a@kit.edu> Message-ID: <5A59F18E-CB1D-4A9C-B4BF-F60F83E0A68E@eggert.org> Roland?s recollection matches mine (used to be a chair of DCCP ~2006) > On 5. Oct 2026, at 12:29, Bless, Roland (TM) via Internet-history wrote: > > Hi, > > my perception was that at the time DCCP was designed, > there was a fear that especially an increasing amount of > multimedia streams may cause congestion problems and > it would be better to to solve them in a single protocol > rather than letting the application developers do it > "somehow" (and maybe neglecting ECN support etc.). > See also the section 2 of RFC4340 > https://datatracker.ietf.org/doc/html/rfc4340#section-2 > > However, given the development of WebRTC and DASH, > people used rather their own application-specific > congestion control mechanisms instead. For example, > WebRTC used more fine-grained RTCP-based feedback > (see also RFC8888) and there were other approaches > developed in the (concluded) RMCAT WG > (https://datatracker.ietf.org/wg/rmcat/about/) as well > such as NADA (RFC8698) and SCReAM (RFC8298). > > The reasons why DCCP had seen no real deployment are > probably manifold, but I guess that NAT/FW traversal > for DCCP as well as the easier development and change > process in the user space contributed to this > (as others noted, this also helped QUIC development and > was a deliberate design choice). > > FWIW, there has been recent work in the IETF on Multipath-DCCP > https://datatracker.ietf.org/doc/rfc9897/ > to support a special use case for providing an MP-DCCP proxy > inside a provider network. The idea was to also support > QUIC and other UDP-based protocols. > > So I disagree that QUIC development hindered DCCP > deployment already, > the work on Media over QUIC (MOQ) started only 2022. > > Regards, > Roland > > On 03.10.26 at 18:26 John Kristoff via Internet-history wrote: >> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet >> history. I don't think it ever really saw much, if any, deployment or >> support in applications. It was removed from the Linux kernel last year. >> Was it too late, too complex, too little, or just deemed unnecessary >> given available alternatives such as QUIC? I don't recall seeing >> much discussion about why it failed to gain traction and I'm interested >> to hear what the collective wisdom of this group might have to say about >> that. > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history -------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 870 bytes Desc: Message signed with OpenPGP URL: From roland.bless at kit.edu Wed Oct 7 05:27:52 2026 From: roland.bless at kit.edu (Bless, Roland (TM)) Date: Wed, 7 Oct 2026 14:27:52 +0200 Subject: [ih] Why did DCCP fail to gain traction? In-Reply-To: <5A59F18E-CB1D-4A9C-B4BF-F60F83E0A68E@eggert.org> References: <20261003112616.3aa794d0@dataplane.org> <87813c62-b5c8-4f03-8bd2-af56e29bdd9a@kit.edu> <5A59F18E-CB1D-4A9C-B4BF-F60F83E0A68E@eggert.org> Message-ID: <62c6b887-80eb-47ed-8b28-fe7d7cb0b076@kit.edu> Hi Lars and all, thanks for the confirmation of my assessment. One additional reason I forgot in my previous mail: many multimedia streams often do not scale continuously and linearly in throughput, but rather in discrete steps of corresponding different quality levels. Therefore, it is often quite application-specific (and/or codec-specific) how a multimedia stream sender (or receiver) reacts to congestion. Moreover, although DCCP offered the possibility of defining and using different congestion control algorithms, it probably did not reduce the app developer burden because one has to implement this scaling logic/behavior anyway at the application layer; using DCCP underneath would rather only complicate things with its own congestion control loop... Moreover, streaming of stored media mainly uses HTTP (also due to the benefit of being able to reuse the existing caching/CDN infrastructure) and DASH is more receiver-controlled and thus quite different to the DCCP model. Regards, Roland On 07.10.26 at 10:49 Lars Eggert wrote: > Roland?s recollection matches mine (used to be a chair of DCCP ~2006) > >> On 5. Oct 2026, at 12:29, Bless, Roland (TM) via Internet-history wrote: >> >> Hi, >> >> my perception was that at the time DCCP was designed, >> there was a fear that especially an increasing amount of >> multimedia streams may cause congestion problems and >> it would be better to to solve them in a single protocol >> rather than letting the application developers do it >> "somehow" (and maybe neglecting ECN support etc.). >> See also the section 2 of RFC4340 >> https://datatracker.ietf.org/doc/html/rfc4340#section-2 >> >> However, given the development of WebRTC and DASH, >> people used rather their own application-specific >> congestion control mechanisms instead. For example, >> WebRTC used more fine-grained RTCP-based feedback >> (see also RFC8888) and there were other approaches >> developed in the (concluded) RMCAT WG >> (https://datatracker.ietf.org/wg/rmcat/about/) as well >> such as NADA (RFC8698) and SCReAM (RFC8298). >> >> The reasons why DCCP had seen no real deployment are >> probably manifold, but I guess that NAT/FW traversal >> for DCCP as well as the easier development and change >> process in the user space contributed to this >> (as others noted, this also helped QUIC development and >> was a deliberate design choice). >> >> FWIW, there has been recent work in the IETF on Multipath-DCCP >> https://datatracker.ietf.org/doc/rfc9897/ >> to support a special use case for providing an MP-DCCP proxy >> inside a provider network. The idea was to also support >> QUIC and other UDP-based protocols. >> >> So I disagree that QUIC development hindered DCCP >> deployment already, >> the work on Media over QUIC (MOQ) started only 2022. >> >> Regards, >> Roland >> >> On 03.10.26 at 18:26 John Kristoff via Internet-history wrote: >>> DCCP (IETF RFC 4330) is/was a relatively new transport in Internet >>> history. I don't think it ever really saw much, if any, deployment or >>> support in applications. It was removed from the Linux kernel last year. >>> Was it too late, too complex, too little, or just deemed unnecessary >>> given available alternatives such as QUIC? I don't recall seeing >>> much discussion about why it failed to gain traction and I'm interested >>> to hear what the collective wisdom of this group might have to say about >>> that. >> -- >> Internet-history mailing list >> Internet-history at elists.isoc.org >> https://elists.isoc.org/mailman/listinfo/internet-history >> - >> Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > From frantisek.borsik at gmail.com Sat Oct 31 00:32:29 2026 From: frantisek.borsik at gmail.com (Frantisek Borsik) Date: Sat, 31 Oct 2026 07:32:29 +0000 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? Message-ID: "Leonard Kleinrock and a team of scientists at UCLA gave life to the Internet at precisely 10:30 PM on October 29, 1969, quite literally changing the world. 57 years later, what does Professor Kleinrock think of the his creation?" https://x.com/lainaminute/status/2115898117229039925 https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr https://www.instagram.com/reel/DfFw5IGSTy9/ All the best, Frank Frantisek (Frank) Borsik In loving memory of Dave T?ht: 1965-2025 https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ https://www.linkedin.com/in/frantisekborsik Signal, Telegram, WhatsApp: +421919416714 iMessage, mobile: +420775230885 Skype: casioa5302ca frantisek.borsik at gmail.com From vgcerf at gmail.com Sat Oct 31 04:16:44 2026 From: vgcerf at gmail.com (vinton cerf) Date: Sat, 31 Oct 2026 07:16:44 -0400 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: The 10/29/1969 was a two node test of the Arpanet and involved connecting a terminal at UCLA to a host at SRI International that were connected via two Interface Message Processors (IMPs) which we would call packet switches today. There was no host level protocol for that test. The protocol that linked the Arpanet hosts was developed under the leadership of Steve Crocker and was eventually called either the host-to-host protocol or Network Control Protocol (or Program) in 1970 (see IETF RFC document series, also started by Steve Crocker; RFC 33 Feb 1970). Three of us worked at the Network Measurement Lab, led by Leonard Kleinrock: Steve Crocker, Vint Cerf and Jon Postel, among others. The Internet development started in the Spring of 1973 at Stanford and was initiated by Bob Kahn (then at DARPA) who invited Vint Cerf to work with him on the project. The Transmission Control Protocol (TCP) protocol was published in May 1974 in IEEE Transactions. By Dec 1974, a complete TCP spec was published in Dec 1974 (RFC 675) written by Cerf, Yogen Dalal and Carl Sunshine at Stanford. Three networks made up the cohort populating the early Internet: Arpanet, Packet Radio network and the Atlantic Packet Satellite network. The first two-network test of the Internet protocols occurred in Summer 1976 linking the Packet Radio network to the Arpanet and was conducted by SRI International. The first three network test was conducted Nov 22, 1977 including Packet Radio, Packet Satellite and Arpanet. Internet went operational on January 1, 1983. On Sat, Oct 31, 2026 at 3:19?AM Frantisek Borsik via Internet-history < internet-history at elists.isoc.org> wrote: > "Leonard Kleinrock and a team of scientists at UCLA gave life to the > Internet at precisely 10:30 PM on October 29, 1969, quite literally > changing the world. > > 57 years later, what does Professor Kleinrock think of the his creation?" > > https://x.com/lainaminute/status/2115898117229039925 > < > https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 > > > > https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr > > https://www.instagram.com/reel/DfFw5IGSTy9/ > > > > > > All the best, > > Frank > Frantisek (Frank) Borsik > > In loving memory of Dave T?ht: 1965-2025 > https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ > > > https://www.linkedin.com/in/frantisekborsik > Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> > iMessage, mobile: +420775230885 <+420%20775%20230%20885> > Skype: casioa5302ca > frantisek.borsik at gmail.com > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: > https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > From jeanjour at comcast.net Sat Oct 31 07:51:54 2026 From: jeanjour at comcast.net (John Day) Date: Sat, 31 Oct 2026 10:51:54 -0400 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: Vint, A slight correction to your note. A APRA PI meeting in early 67 rejected Roberts plans for the ARPANET because their systems were too loaded as it was. But Wes Clark suggested putting minicomputers in front of the hosts as a front-end, hence the IMPs. If you look closely, the IMP is really a virtual circuit packet switch on the backend and a front-end to the host. Host-IMP protocol is part of the front-end part that sets up connections between hosts and reassembles packets into multi-packet messages. It was the front-end function that was the source of the deadlocks we talk about. Take care, John > On Oct 31, 2026, at 07:16, vinton cerf via Internet-history wrote: > > The 10/29/1969 was a two node test of the Arpanet and involved connecting a > terminal at UCLA to a host at SRI International that were connected via two > Interface Message Processors (IMPs) which we would call packet switches > today. There was no host level protocol for that test. The protocol that > linked the Arpanet hosts was developed under the leadership of Steve > Crocker and was eventually called either the host-to-host protocol or > Network Control Protocol (or Program) in 1970 (see IETF RFC document > series, also started by Steve Crocker; RFC 33 Feb 1970). Three of us worked > at the Network Measurement Lab, led by Leonard Kleinrock: Steve Crocker, > Vint Cerf and Jon Postel, among others. The Internet development started in > the Spring of 1973 at Stanford and was initiated by Bob Kahn (then at > DARPA) who invited Vint Cerf to work with him on the project. The > Transmission Control Protocol (TCP) protocol was published in May 1974 in > IEEE Transactions. By Dec 1974, a complete TCP spec was published in Dec > 1974 (RFC 675) written by Cerf, Yogen Dalal and Carl Sunshine at Stanford. > Three networks made up the cohort populating the early Internet: Arpanet, > Packet Radio network and the Atlantic Packet Satellite network. The first > two-network test of the Internet protocols occurred in Summer 1976 linking > the Packet Radio network to the Arpanet and was conducted by SRI > International. The first three network test was conducted Nov 22, 1977 > including Packet Radio, Packet Satellite and Arpanet. Internet went > operational on January 1, 1983. > > > > > > On Sat, Oct 31, 2026 at 3:19?AM Frantisek Borsik via Internet-history < > internet-history at elists.isoc.org> wrote: > >> "Leonard Kleinrock and a team of scientists at UCLA gave life to the >> Internet at precisely 10:30 PM on October 29, 1969, quite literally >> changing the world. >> >> 57 years later, what does Professor Kleinrock think of the his creation?" >> >> https://x.com/lainaminute/status/2115898117229039925 >> < >> https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 >>> >> >> https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr >> >> https://www.instagram.com/reel/DfFw5IGSTy9/ >> >> >> >> >> >> All the best, >> >> Frank >> Frantisek (Frank) Borsik >> >> In loving memory of Dave T?ht: 1965-2025 >> https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ >> >> >> https://www.linkedin.com/in/frantisekborsik >> Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> >> iMessage, mobile: +420775230885 <+420%20775%20230%20885> >> Skype: casioa5302ca >> frantisek.borsik at gmail.com >> -- >> Internet-history mailing list >> Internet-history at elists.isoc.org >> https://elists.isoc.org/mailman/listinfo/internet-history >> - >> Unsubscribe: >> https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history >> > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history From steve at shinkuro.com Sat Oct 31 08:13:11 2026 From: steve at shinkuro.com (Steve Crocker) Date: Sat, 31 Oct 2026 11:13:11 -0400 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: We should mention that the late evening event on 29 October 1969 consisted of just two people: Charley Kline at UCLA and Bill Duvall at SRI. The software at SRI connected the IMP to its terminal management software inside its operating system. The software on the UCLA side was primarily a simple ad hoc user-level process that connected the user's terminal to the IMP. The SRI system had command completion, so when Charley typed the G after the LO, the SRI system attempted to echo back GIN. Bill's software didn't have room for three characters arriving at once, and the connection crashed. Bill fixed it quickly and the test continued. The event might not have gained any attention except Charley dutifully documented it in the lab notebook and Kleinrock, reading the log later, waxed poetic about "LO". Steve On Sat, Oct 31, 2026 at 7:17?AM vinton cerf via Internet-history < internet-history at elists.isoc.org> wrote: > The 10/29/1969 was a two node test of the Arpanet and involved connecting a > terminal at UCLA to a host at SRI International that were connected via two > Interface Message Processors (IMPs) which we would call packet switches > today. There was no host level protocol for that test. The protocol that > linked the Arpanet hosts was developed under the leadership of Steve > Crocker and was eventually called either the host-to-host protocol or > Network Control Protocol (or Program) in 1970 (see IETF RFC document > series, also started by Steve Crocker; RFC 33 Feb 1970). Three of us worked > at the Network Measurement Lab, led by Leonard Kleinrock: Steve Crocker, > Vint Cerf and Jon Postel, among others. The Internet development started in > the Spring of 1973 at Stanford and was initiated by Bob Kahn (then at > DARPA) who invited Vint Cerf to work with him on the project. The > Transmission Control Protocol (TCP) protocol was published in May 1974 in > IEEE Transactions. By Dec 1974, a complete TCP spec was published in Dec > 1974 (RFC 675) written by Cerf, Yogen Dalal and Carl Sunshine at Stanford. > Three networks made up the cohort populating the early Internet: Arpanet, > Packet Radio network and the Atlantic Packet Satellite network. The first > two-network test of the Internet protocols occurred in Summer 1976 linking > the Packet Radio network to the Arpanet and was conducted by SRI > International. The first three network test was conducted Nov 22, 1977 > including Packet Radio, Packet Satellite and Arpanet. Internet went > operational on January 1, 1983. > > > > > > On Sat, Oct 31, 2026 at 3:19?AM Frantisek Borsik via Internet-history < > internet-history at elists.isoc.org> wrote: > > > "Leonard Kleinrock and a team of scientists at UCLA gave life to the > > Internet at precisely 10:30 PM on October 29, 1969, quite literally > > changing the world. > > > > 57 years later, what does Professor Kleinrock think of the his creation?" > > > > https://x.com/lainaminute/status/2115898117229039925 > > < > > > https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 > > > > > > > https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr > > > > https://www.instagram.com/reel/DfFw5IGSTy9/ > > > > > > > > > > > > All the best, > > > > Frank > > Frantisek (Frank) Borsik > > > > In loving memory of Dave T?ht: 1965-2025 > > https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ > > > > > > https://www.linkedin.com/in/frantisekborsik > > Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> > <+421%20919%20416%20714> > > iMessage, mobile: +420775230885 <+420%20775%20230%20885> > <+420%20775%20230%20885> > > Skype: casioa5302ca > > frantisek.borsik at gmail.com > > -- > > Internet-history mailing list > > Internet-history at elists.isoc.org > > https://elists.isoc.org/mailman/listinfo/internet-history > > - > > Unsubscribe: > > > https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > > > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: > https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > -- Sent by a Verified sender From lk at cs.ucla.edu Sat Oct 31 09:09:53 2026 From: lk at cs.ucla.edu (Leonard Kleinrock) Date: Sat, 31 Oct 2026 09:09:53 -0700 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: The ?message? we were trying to send, ?login? was not designed to be of eternal significance as we celebrate it on Oct 29 each year. Consider Neal Armstrong?s dramatic message ?? one giant leap for mankind.? Or Samuel Morse?s ?What hath God wrought?. Those guys were smart, they understood public relations, the media, the press. We were just a bunch of nerds doing an engineering job. However, the message we sent ?Lo? (which I later embellished to ?Lo and Behold?) could not have been a more succinct, more powerful, more prophetic message! Len > On Oct 31, 2026, at 8:13?AM, Steve Crocker via Internet-history wrote: > > We should mention that the late evening event on 29 October 1969 consisted > of just two people: Charley Kline at UCLA and Bill Duvall at SRI. The > software at SRI connected the IMP to its terminal management software > inside its operating system. The software on the UCLA side was primarily a > simple ad hoc user-level process that connected the user's terminal to the > IMP. The SRI system had command completion, so when Charley typed the G > after the LO, the SRI system attempted to echo back GIN. Bill's software > didn't have room for three characters arriving at once, and the connection > crashed. Bill fixed it quickly and the test continued. The event might > not have gained any attention except Charley dutifully documented it in the > lab notebook and Kleinrock, reading the log later, waxed poetic about "LO". > > Steve > > > On Sat, Oct 31, 2026 at 7:17?AM vinton cerf via Internet-history < > internet-history at elists.isoc.org > wrote: > >> The 10/29/1969 was a two node test of the Arpanet and involved connecting a >> terminal at UCLA to a host at SRI International that were connected via two >> Interface Message Processors (IMPs) which we would call packet switches >> today. There was no host level protocol for that test. The protocol that >> linked the Arpanet hosts was developed under the leadership of Steve >> Crocker and was eventually called either the host-to-host protocol or >> Network Control Protocol (or Program) in 1970 (see IETF RFC document >> series, also started by Steve Crocker; RFC 33 Feb 1970). Three of us worked >> at the Network Measurement Lab, led by Leonard Kleinrock: Steve Crocker, >> Vint Cerf and Jon Postel, among others. The Internet development started in >> the Spring of 1973 at Stanford and was initiated by Bob Kahn (then at >> DARPA) who invited Vint Cerf to work with him on the project. The >> Transmission Control Protocol (TCP) protocol was published in May 1974 in >> IEEE Transactions. By Dec 1974, a complete TCP spec was published in Dec >> 1974 (RFC 675) written by Cerf, Yogen Dalal and Carl Sunshine at Stanford. >> Three networks made up the cohort populating the early Internet: Arpanet, >> Packet Radio network and the Atlantic Packet Satellite network. The first >> two-network test of the Internet protocols occurred in Summer 1976 linking >> the Packet Radio network to the Arpanet and was conducted by SRI >> International. The first three network test was conducted Nov 22, 1977 >> including Packet Radio, Packet Satellite and Arpanet. Internet went >> operational on January 1, 1983. >> >> >> >> >> >> On Sat, Oct 31, 2026 at 3:19?AM Frantisek Borsik via Internet-history < >> internet-history at elists.isoc.org> wrote: >> >>> "Leonard Kleinrock and a team of scientists at UCLA gave life to the >>> Internet at precisely 10:30 PM on October 29, 1969, quite literally >>> changing the world. >>> >>> 57 years later, what does Professor Kleinrock think of the his creation?" >>> >>> https://x.com/lainaminute/status/2115898117229039925 >>> < >>> >> https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 >>>> >>> >>> https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr >>> >>> https://www.instagram.com/reel/DfFw5IGSTy9/ >>> >>> >>> >>> >>> >>> All the best, >>> >>> Frank >>> Frantisek (Frank) Borsik >>> >>> In loving memory of Dave T?ht: 1965-2025 >>> https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ >>> >>> >>> https://www.linkedin.com/in/frantisekborsik >>> Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> >> <+421%20919%20416%20714> >>> iMessage, mobile: +420775230885 <+420%20775%20230%20885> >> <+420%20775%20230%20885> >>> Skype: casioa5302ca >>> frantisek.borsik at gmail.com >>> -- >>> Internet-history mailing list >>> Internet-history at elists.isoc.org >>> https://elists.isoc.org/mailman/listinfo/internet-history >>> - >>> Unsubscribe: >>> >> https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history >>> >> -- >> Internet-history mailing list >> Internet-history at elists.isoc.org >> https://elists.isoc.org/mailman/listinfo/internet-history >> - >> Unsubscribe: >> https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history >> > > > -- > Sent by a Verified > > sender > -- > Internet-history mailing list > Internet-history at elists.isoc.org > https://elists.isoc.org/mailman/listinfo/internet-history > - > Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history From vgcerf at gmail.com Sat Oct 31 09:23:25 2026 From: vgcerf at gmail.com (vinton cerf) Date: Sat, 31 Oct 2026 12:23:25 -0400 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: Thanks John, correct about Wes contribution for sure. The IMP presented a packet interface (BBN 1822) but internally set up a two way connection between end IMPs. Between IMPs the packets flowed in store-and-forward fashion and allowed for adaptive alternative routing, so the routing was not a fixed circuit although the end-point IMPs established an end/end relationship that could be seen as a 'circuit' especially considering reservation of reassembly space as part of the "set up". v On Sat, Oct 31, 2026 at 10:51?AM John Day wrote: > Vint, > A slight correction to your note. > > A APRA PI meeting in early 67 rejected Roberts plans for the ARPANET > because their systems were too loaded as it was. But Wes Clark suggested > putting minicomputers in front of the hosts as a front-end, hence the IMPs. > If you look closely, the IMP is really a virtual circuit packet switch on > the backend and a front-end to the host. Host-IMP protocol is part of the > front-end part that sets up connections between hosts and reassembles > packets into multi-packet messages. It was the front-end function that was > the source of the deadlocks we talk about. > > Take care, > John > > > On Oct 31, 2026, at 07:16, vinton cerf via Internet-history < > internet-history at elists.isoc.org> wrote: > > > > The 10/29/1969 was a two node test of the Arpanet and involved > connecting a > > terminal at UCLA to a host at SRI International that were connected via > two > > Interface Message Processors (IMPs) which we would call packet switches > > today. There was no host level protocol for that test. The protocol that > > linked the Arpanet hosts was developed under the leadership of Steve > > Crocker and was eventually called either the host-to-host protocol or > > Network Control Protocol (or Program) in 1970 (see IETF RFC document > > series, also started by Steve Crocker; RFC 33 Feb 1970). Three of us > worked > > at the Network Measurement Lab, led by Leonard Kleinrock: Steve Crocker, > > Vint Cerf and Jon Postel, among others. The Internet development started > in > > the Spring of 1973 at Stanford and was initiated by Bob Kahn (then at > > DARPA) who invited Vint Cerf to work with him on the project. The > > Transmission Control Protocol (TCP) protocol was published in May 1974 in > > IEEE Transactions. By Dec 1974, a complete TCP spec was published in Dec > > 1974 (RFC 675) written by Cerf, Yogen Dalal and Carl Sunshine at > Stanford. > > Three networks made up the cohort populating the early Internet: Arpanet, > > Packet Radio network and the Atlantic Packet Satellite network. The first > > two-network test of the Internet protocols occurred in Summer 1976 > linking > > the Packet Radio network to the Arpanet and was conducted by SRI > > International. The first three network test was conducted Nov 22, 1977 > > including Packet Radio, Packet Satellite and Arpanet. Internet went > > operational on January 1, 1983. > > > > > > > > > > > > On Sat, Oct 31, 2026 at 3:19?AM Frantisek Borsik via Internet-history < > > internet-history at elists.isoc.org> wrote: > > > >> "Leonard Kleinrock and a team of scientists at UCLA gave life to the > >> Internet at precisely 10:30 PM on October 29, 1969, quite literally > >> changing the world. > >> > >> 57 years later, what does Professor Kleinrock think of the his > creation?" > >> > >> https://x.com/lainaminute/status/2115898117229039925 > >> < > >> > https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 > >>> > >> > >> https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr > >> > >> https://www.instagram.com/reel/DfFw5IGSTy9/ > >> > >> > >> > >> > >> > >> All the best, > >> > >> Frank > >> Frantisek (Frank) Borsik > >> > >> In loving memory of Dave T?ht: 1965-2025 > >> https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ > >> > >> > >> https://www.linkedin.com/in/frantisekborsik > >> Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> > <+421%20919%20416%20714> > >> iMessage, mobile: +420775230885 <+420%20775%20230%20885> > <+420%20775%20230%20885> > >> Skype: casioa5302ca > >> frantisek.borsik at gmail.com > >> -- > >> Internet-history mailing list > >> Internet-history at elists.isoc.org > >> https://elists.isoc.org/mailman/listinfo/internet-history > >> - > >> Unsubscribe: > >> > https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > >> > > -- > > Internet-history mailing list > > Internet-history at elists.isoc.org > > https://elists.isoc.org/mailman/listinfo/internet-history > > - > > Unsubscribe: > https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history > > From jeanjour at comcast.net Sat Oct 31 11:22:38 2026 From: jeanjour at comcast.net (John Day) Date: Sat, 31 Oct 2026 14:22:38 -0400 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: <0CAB73D1-A85D-4144-994E-3763A3003DDF@comcast.net> You are correct, The ARPANET was what one might call a ?weak virtual circuit? as opposed to a pure datagram, like IP.. (The packets followed the same path unless there was the routing caused a change. However, it was the front-end functionality that reassembled packets into message, not by intervening IMPs. The perspective that hosts were considered part of the network is consistent with that. They are subtle differences but they made a big difference in the thinking going forward. In fact, Hosts are still considered not part of the network. IMP-Host created a connection from Host to Host. Then the Host-to-Host protocol created a connection from process-to-process. Whereas TCP created process-to-process connections and there was no underlying host-to-host connection, like what IMP-Host did. > On Oct 31, 2026, at 12:23, vinton cerf wrote: > > Thanks John, > correct about Wes contribution for sure. The IMP presented a packet interface (BBN 1822) but internally set up a two way connection between end IMPs. Between IMPs the packets flowed in store-and-forward fashion and allowed for adaptive alternative routing, so the routing was not a fixed circuit although the end-point IMPs established an end/end relationship that could be seen as a 'circuit' especially considering reservation of reassembly space as part of the "set up". > > v > > > On Sat, Oct 31, 2026 at 10:51?AM John Day > wrote: >> Vint, >> A slight correction to your note. >> >> A APRA PI meeting in early 67 rejected Roberts plans for the ARPANET because their systems were too loaded as it was. But Wes Clark suggested putting minicomputers in front of the hosts as a front-end, hence the IMPs. If you look closely, the IMP is really a virtual circuit packet switch on the backend and a front-end to the host. Host-IMP protocol is part of the front-end part that sets up connections between hosts and reassembles packets into multi-packet messages. It was the front-end function that was the source of the deadlocks we talk about. >> >> Take care, >> John >> >> > On Oct 31, 2026, at 07:16, vinton cerf via Internet-history > wrote: >> > >> > The 10/29/1969 was a two node test of the Arpanet and involved connecting a >> > terminal at UCLA to a host at SRI International that were connected via two >> > Interface Message Processors (IMPs) which we would call packet switches >> > today. There was no host level protocol for that test. The protocol that >> > linked the Arpanet hosts was developed under the leadership of Steve >> > Crocker and was eventually called either the host-to-host protocol or >> > Network Control Protocol (or Program) in 1970 (see IETF RFC document >> > series, also started by Steve Crocker; RFC 33 Feb 1970). Three of us worked >> > at the Network Measurement Lab, led by Leonard Kleinrock: Steve Crocker, >> > Vint Cerf and Jon Postel, among others. The Internet development started in >> > the Spring of 1973 at Stanford and was initiated by Bob Kahn (then at >> > DARPA) who invited Vint Cerf to work with him on the project. The >> > Transmission Control Protocol (TCP) protocol was published in May 1974 in >> > IEEE Transactions. By Dec 1974, a complete TCP spec was published in Dec >> > 1974 (RFC 675) written by Cerf, Yogen Dalal and Carl Sunshine at Stanford. >> > Three networks made up the cohort populating the early Internet: Arpanet, >> > Packet Radio network and the Atlantic Packet Satellite network. The first >> > two-network test of the Internet protocols occurred in Summer 1976 linking >> > the Packet Radio network to the Arpanet and was conducted by SRI >> > International. The first three network test was conducted Nov 22, 1977 >> > including Packet Radio, Packet Satellite and Arpanet. Internet went >> > operational on January 1, 1983. >> > >> > >> > >> > >> > >> > On Sat, Oct 31, 2026 at 3:19?AM Frantisek Borsik via Internet-history < >> > internet-history at elists.isoc.org > wrote: >> > >> >> "Leonard Kleinrock and a team of scientists at UCLA gave life to the >> >> Internet at precisely 10:30 PM on October 29, 1969, quite literally >> >> changing the world. >> >> >> >> 57 years later, what does Professor Kleinrock think of the his creation?" >> >> >> >> https://x.com/lainaminute/status/2115898117229039925 >> >> < >> >> https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 >> >>> >> >> >> >> https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr >> >> >> >> https://www.instagram.com/reel/DfFw5IGSTy9/ >> >> >> >> >> >> >> >> >> >> >> >> All the best, >> >> >> >> Frank >> >> Frantisek (Frank) Borsik >> >> >> >> In loving memory of Dave T?ht: 1965-2025 >> >> https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ >> >> >> >> >> >> https://www.linkedin.com/in/frantisekborsik >> >> Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> >> >> iMessage, mobile: +420775230885 <+420%20775%20230%20885> >> >> Skype: casioa5302ca >> >> frantisek.borsik at gmail.com >> >> -- >> >> Internet-history mailing list >> >> Internet-history at elists.isoc.org >> >> https://elists.isoc.org/mailman/listinfo/internet-history >> >> - >> >> Unsubscribe: >> >> https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history >> >> >> > -- >> > Internet-history mailing list >> > Internet-history at elists.isoc.org >> > https://elists.isoc.org/mailman/listinfo/internet-history >> > - >> > Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history >> From aam3sendonly at gmail.com Sat Oct 31 13:00:29 2026 From: aam3sendonly at gmail.com (Alexander McKenzie) Date: Sat, 31 Oct 2026 16:00:29 -0400 Subject: [ih] Fwd: Fw: Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: <1929866901.804568.1793476681600@mail.yahoo.com> References: <95864229.323394.1793457986498@mail.yahoo.com> <1929866901.804568.1793476681600@mail.yahoo.com> Message-ID: In addition to "Leonard Kleinrock and a team of scientists at UCLA" who sent the first Host-to-Host messages over the ARPAnet (not the Internet) in 1969 it is reasonable to say that those who "gave life to" the ARPANET include: - the visionary thinkers at ARPA who came up with the idea and the funding - the extraordinary engineers at Bolt Beranek and Newman Inc who produced the working ARPAnet hardware and software in 9 months - the collection of Principal Investigators and grad students at the many computer science sites supported by ARPA who comprised the Network Working Group which developed ideas for the practical use of the ARPAnet Why must we continue to read accounts which try to give credit for this astounding development to one man who was very much on the sidelines of the actual work? Alex McKenzie On Saturday, October 31, 2026 at 03:19:30 AM EDT, Frantisek Borsik via Internet-history wrote: "Leonard Kleinrock and a team of scientists at UCLA gave life to the Internet at precisely 10:30 PM on October 29, 1969, quite literally changing the world. 57 years later, what does Professor Kleinrock think of the his creation?" https://x.com/lainaminute/status/2115898117229039925 < https://x.com/lainaminute/status/2115898117229039925?a=bXFqldnx0o8OUK9A6xw&s=46 > https://www.facebook.com/share/v/1BU8EMAfdG/?mibextid=wwXIfr https://www.instagram.com/reel/DfFw5IGSTy9/ All the best, Frank Frantisek (Frank) Borsik In loving memory of Dave T?ht: 1965-2025 https://libreqos.io/2025/04/01/in-loving-memory-of-dave/ https://www.linkedin.com/in/frantisekborsik Signal, Telegram, WhatsApp: +421919416714 <+421%20919%20416%20714> iMessage, mobile: +420775230885 <+420%20775%20230%20885> Skype: casioa5302ca frantisek.borsik at gmail.com -- Internet-history mailing list Internet-history at elists.isoc.org https://elists.isoc.org/mailman/listinfo/internet-history - Unsubscribe: https://app.smartsheet.com/b/form/9b6ef0621638436ab0a9b23cb0668b0b?The%20list%20to%20be%20unsubscribed%20from=Internet-history From karl at iwl.com Sat Oct 31 13:34:57 2026 From: karl at iwl.com (Karl Auerbach) Date: Sat, 31 Oct 2026 13:34:57 -0700 Subject: [ih] Internet: 57 years later, what does Professor Kleinrock think of the his creation? In-Reply-To: References: Message-ID: On 10/31/26 4:16 AM, vinton cerf via Internet-history wrote: > The 10/29/1969 was a two node test of the Arpanet and involved connecting a > terminal at UCLA to a host at SRI Internationa There is a play, "Rosencrantz and Guildenstern Are Dead", in which two characters who have rather little to do with the main plot of the play Hamlet, observe the goings on in Castle Elsinore, in Hamlet. I, rather similarly, had nothing to do with that early IMP phase, and even less to do with the UCLA-SRI test, but I may have been close by... It was very likely that I was in the room next door. During that period I was working nights preparing data for the IBM 7094 which lived in the room next to IMP #1.? We could hear things through the thin partition wall between the rooms - usually we heard the squeals of an AM radio that was being overloaded by the RF coming from the computers - but sometimes we heard voices. A bit further away, and of uncertain date, certain members of the UCLA Computer Club ... usually led by person who shall remain anonymous and known only by the letters "M*rk K*mpe" ... had been dropping "interesting" things - superballs frozen in liquid nitrogen, empty radiation containers, etc - off the roof of nine-story tall Boelter Hall (the landing area was the collection of cars that had been crashed by my group, the Institution of Traffic and Transportation Engineering).? That Computer Club cadre laid eyes on IMP #1, admired the lifting hooks on its top, and became intrigued by the word "ruggedized".? They began to wonder whether IMP #1 would make an interesting new item for the roof-drop tests.? Fortunately for the Internet (and unfortunately for a vending machine repairman) their gaze was distracted by a troublesome ice cream vending machine. ? ? ? ? --karl-- From jack at 3kitty.org Sat Oct 31 19:50:01 2026 From: jack at 3kitty.org (Jack Haverty) Date: Sat, 31 Oct 2026 19:50:01 -0700 Subject: [ih] J.C.R. Licklider Message-ID: <7d6f08de-4571-4c26-b343-4f8a9fdb2324@3kitty.org> Speaking of Internet History, the ARPANET et al --- There's another player from the early days of The Internet that may not be well known to Internet historians - J.C.R. Licklider From 1970 through 1977, I was in Licklider's group at MIT, first as a student and then as a member of his research staff.? ?Sometime in the early 1960s, Lick (as everyone called him then) wrote several papers describing his vision of a "intergalactic network" of computers, all somehow able to communicate with each other, and working together to help humans "do everything humans do."? ?His vision included the notion that everyone would have some kind of "personal" computer that would interact with other computers even when the human was doing something else. Of course, in 1975 a "personal computer" was an account on some large timeshared machine, and the human interacted with it only when s/he was "logged in" at some kind of terminal.? Today, humans have computers in their pockets much more powerful than the 1970s machines, and able to interact with huge numbers of other computers using this thing we call The Internet.? ?As AI and its "agents" emerge, we may be getting very close to Lick's vision of vast numbers of interacting computers helping humans do everything humans do. During the 1970s, I was thoroughly indoctrinated into Lick's "intergalactic network" vision of how computers would be integrated into society.? ?In retrospect, I've realized that I spent my entire career somehow involved in building Lick's vision, as part of the huge community that made it happen.? It's been a wild ride and there's still a question of whether we'll see a utopian future or one where AI kills us all. For anyone interested in the history of the Internet, I highly recommend a book by Mitchell Waldrop, called "The Dream Machine". It is essentially a biography of Lick, but also describes much of the 1960-1990 history of computing.? Among the details you may not know: - Lick's training was in psychology and psychoacoustics, not computer science. - The Information Processing Techniques Office (IPTO) of ARPA was formed to explore use of computers.? Lick was the first Director of IPTO, and the ARPANET was a means of starting work on his vision; - Prior to joining ARPA, Lick worked at BBN, and lobbied for the company's first computer purchase.? It was necessary to process data associated with the study of acoustics; later, ARPA awarded the ARPANET contract to BBN;? Connection? - Lick was very much a "do it" person, preferring functioning systems over theory;? he described what we now call "agents", but he called them Olivers - Lick's vision was continued after he retired by his "chief of staff" at MIT, Al Vezza, who convinced Tim Berners-Lee to come to MIT and lead the W3C from there.? This happened too late to be covered in Waldrop's book.? The Web was an important component of Lick's vision and W3C was a means to drive its evolution.? Al used to be my boss and he contacted me to get Oracle to join W3C as a Founding Member and I served as the corporate representative. There were a lot of people involved in the early years of what is now The Internet, and this book describes a lot of the interactions and behind the scenes activity that was involved.? Again, I highly recommend it.? I found that the parts of the book that describe things that happened while I was "in the room" are quite accurate and often explain the "why" of things I remember happening but never knew the full story. /Jack Haverty -------------- next part -------------- A non-text attachment was scrubbed... Name: OpenPGP_signature.asc Type: application/pgp-signature Size: 665 bytes Desc: OpenPGP digital signature URL: From brian.e.carpenter at gmail.com Sat Oct 31 22:07:27 2026 From: brian.e.carpenter at gmail.com (Brian E Carpenter) Date: Sun, 1 Nov 2026 18:07:27 +1300 Subject: [ih] W3C origins [was: Re: J.C.R. Licklider] In-Reply-To: <7d6f08de-4571-4c26-b343-4f8a9fdb2324@3kitty.org> References: <7d6f08de-4571-4c26-b343-4f8a9fdb2324@3kitty.org> Message-ID: <0cd61b08-eb5c-424e-b216-f352afd89ab1@gmail.com> On 01-Nov-26 15:50, Jack Haverty via Internet-history wrote: > Speaking of Internet History, the ARPANET et al --- There's another > player from the early days of The Internet that may not be well known to > Internet historians - J.C.R. Licklider He's fully credited in any serious history of the Internet, I think, e.g. Katie Hafner's book. > - Lick's vision was continued after he retired by his "chief of staff" > at MIT, Al Vezza, who convinced Tim Berners-Lee to come to MIT and lead > the W3C from there. I would add that Michael Dertouzos was *at least* as influential as Al in attracting TimBL to MIT. Probably more, because Dertouzos's old pal George Metakides (an MIT alum) was the senior official in the European Commissionin charge of funding the European end of the W3C. My understanding at the time was that Dertouzos and Metakides (they were both Greek) had decided that the main part of the W3C would be at MIT, with European Commission (EC) funding, but with a small European "pole". Metakides thought it would be a fine idea to place the European unit at CERN, but CERN refused to be part of an exercise whose main result would be to send European funds to the USA. Al Vezza was very much in the room for these discussions. I wasn't, but I knew all the CERN participants, and in fact met them in the departure lounge at Brussels airport on their way back from the critical meeting. (I was in Brussels the same day for a meeting related to growing Internet capacity in Europe.) The CERN team in that discussion, from memory, was Mike Sendall, Tim B-L, Robert Cailliau, and Francois Fluckiger. Maybe David Williams, our Division Leader, was there too. All of them except Tim were flabbergasted by the idea that CERN (a non-EC institution) should be used to route money from the EC to MIT. I heard within a few days that the CERN management definitely refused this. It seemed politically dangerous and was it even legal? Also it seemed outside CERN's mission as a physics laboratory. And nobody missed that Metakides and Dertouzos were buddies. So in the end, INRIA in France acted as the European pole. Regards/Ng? mihi Brian Carpenter From jack at 3kitty.org Sat Oct 31 23:41:15 2026 From: jack at 3kitty.org (Jack Haverty) Date: Sat, 31 Oct 2026 23:41:15 -0700 Subject: [ih] W3C origins [was: Re: J.C.R. Licklider] In-Reply-To: <0cd61b08-eb5c-424e-b216-f352afd89ab1@gmail.com> References: <7d6f08de-4571-4c26-b343-4f8a9fdb2324@3kitty.org> <0cd61b08-eb5c-424e-b216-f352afd89ab1@gmail.com> Message-ID: <8ec8bbda-ae3c-4b2d-bb67-3ab49a909dd5@3kitty.org> Hi Brian, Thanks for the additional info on W3C.? ?All of that occurred before Al contacted me, so I didn't know anything about it.? FYI, here's another view of that founding part of the W3C history, from Dave Walden's interview of Al Vezza in 2012.? You're mentioned in it: https://www.walden-family.com/ieee/galley-proof-anhc-34-2-intv.pdf There was quite a bit of politics involved in the History of The Internet -- what Lick called the "Multinet". /Jack Haverty On 10/31/26 22:07, Brian E Carpenter wrote: > On 01-Nov-26 15:50, Jack Haverty via Internet-history wrote: > >> Speaking of Internet History, the ARPANET et al --- There's another >> player from the early days of The Internet that may not be well known to >> Internet historians - J.C.R. Licklider > > He's fully credited in any serious history of the Internet, I think, > e.g. Katie Hafner's book. > >> - Lick's vision was continued after he retired by his "chief of >> staff" at MIT, Al Vezza, who convinced Tim Berners-Lee to come to MIT >> and lead the W3C from there. > > I would add that Michael Dertouzos was *at least* as influential as Al > in attracting TimBL to MIT. Probably more, because Dertouzos's old pal > George Metakides (an MIT alum) was the senior official in the European > Commissionin charge of funding the European end of the W3C. > > My understanding at the time was that Dertouzos and Metakides (they > were both Greek) had decided that the main part of the W3C would be at > MIT, with European Commission (EC) funding, but with a small European > "pole". Metakides thought it would be a fine idea to place the European > unit at CERN, but CERN refused to be part of an exercise whose main > result would be to send European funds to the USA. > > Al Vezza was very much in the room for these discussions. I wasn't, but > I knew all the CERN participants, and in fact met them in the departure > lounge at Brussels airport on their way back from the critical meeting. > (I was in Brussels the same day for a meeting related to growing Internet > capacity in Europe.) The CERN team in that discussion, from memory, was > Mike Sendall, Tim B-L, Robert Cailliau, and Francois Fluckiger. Maybe > David > Williams, our Division Leader, was there too. All of them except Tim were > flabbergasted by the idea that CERN (a non-EC institution) should be used > to route money from the EC to MIT. > > I heard within a few days that the CERN management definitely refused > this. It seemed politically dangerous and was it even legal? Also it > seemed > outside CERN's mission as a physics laboratory. And nobody missed that > Metakides and Dertouzos were buddies. So in the end, INRIA in France > acted as the European pole. > > Regards/Ng? mihi > ?? Brian Carpenter -------------- next part -------------- A non-text attachment was scrubbed... Name: OpenPGP_signature.asc Type: application/pgp-signature Size: 665 bytes Desc: OpenPGP digital signature URL: